Updating the development environment

Updating the development environment

Follow these instructions if you have already installed the Hyperledger Composer development tools, and you wish to update your installation to the latest version of Hyperledger Composer.

Before you begin

These instructions assume that you've installed the development tools and used them before. If you have not installed the development tools before, then follow the instructions in Installing the development environment.

Updating components

Step 1: Update the CLI tools

Any running instances of the CLI tools should be stopped before continuing. If you have any running instances of the Composer REST server, ensure that those instances are stopped before continuing. You can look for the process composer-rest-server if you are not sure if there are any running instances.

  1. Uninstall the currently installed version of all the CLI tools:

    npm uninstall -g composer-cli composer-rest-server generator-hyperledger-composer
    
  2. Install the latest version of all of the CLI tools:

    npm install -g composer-cli@0.20 composer-rest-server@0.20 generator-hyperledger-composer@0.20
    

Step 2: Update Playground

If you have installed the browser app "Playground" on your development machine, you will need to update this as well. If you have any running instances of the browser app, ensure that those instances are stopped before continuing. You can look for the process composer-playground if you are not sure if there are any running instances.

  1. Uninstall the currently installed version of the browser app:

    npm uninstall -g composer-playground
    
  2. Install the latest version of the browser app:

    npm install -g composer-playground@0.20
    

Congratulations, you have updated your development environment with the latest version of the development tools. You can now continue developing your blockchain applications using the latest features and bug fixes!

What Next?